Table Top Exercise - Disaster Recovery 8/4/2023
Incident Report for Finicast
Resolved
We have confirmed with customers that the Finicast platform is now accessible. Please use https://app.finicast.com to access the platform. We apologize for any inconvenience that this issue may have caused. We appreciate your patience while we document a comprehensive root cause analysis. If you have any further questions, concerns, or continue to receive an error, please don't hesitate to contact us at support@finicast.com.
Posted Aug 04, 2023 - 05:49 UTC
Identified
We are restoring our services, please give us 1 hour for the procedure to be completed. Thank you for being a valued Finicast customer.
Posted Aug 04, 2023 - 04:49 UTC
Update
We have activated our disaster recovery as the Bay Area earthquake was impacted by the reported service interruption. All engineers are actively working to restore service to the Finicast platform. As we work to restore our service, please use https://app-dr1.finicast.com to access the platform as we work through this issue. Thank you for being a valued Finicast customer. If you continue to experience issues please don’t hesitate to contact us at support@finicast.com.
Posted Aug 04, 2023 - 04:46 UTC
Investigating
We are receiving reports of our customers experiencing issues accessing the Finicast platform. Our engineers are aware and actively investigating. We will provide regular updates on this page until the issues are resolved. We apologize for the inconvenience this may be causing and appreciate your patience.
Posted Aug 04, 2023 - 04:33 UTC
This incident affected: Prod site and Cluster-FTA.